AWS Issue
Incident Report for vCreative
Postmortem

Amazon Web Services (AWS) had an issue with their Route 53 service that started a little after 11 AM (PDT). While they were having issues, it caused changes in the service to backup while waiting to be queued. This was not an issue for vCreative because we had already scaled up to our accommodate mid day traffic earlier in the morning.

In the afternoon however, as our processes took over and our website traffic decreased, we started releasing servers. When this happened, the servers went away, but Route 53 could not propagate the DNS changes out so that other servers knew they were no longer there, this caused many requests to fail simply trying to talk to servers that were no longer there. When amazon fixed their interrupted service, and processed through the backlog, vCreative service returned to normal.

We apologize for any inconvenience and want to thank our users for their patience.

Posted May 10, 2019 - 23:51 EDT

Resolved
This incident has been resolved.
Posted May 10, 2019 - 23:00 EDT
Monitoring
The Amazon Route53 fix continues to deploy. We will continue to monitor and update.
Posted May 10, 2019 - 22:40 EDT
Identified
AWS has identified the routing issue and their fix is propagating.
Posted May 10, 2019 - 22:20 EDT
Update
An issue with AWS Route 53 that caused issues with DNS propogation is affecting vCreative's connection to it's backend servers and databases. AWS have identified and are working on fixing the issue currently, We will update as soon as we can.
Posted May 10, 2019 - 21:42 EDT
Investigating
We are looking into a reported AWS router issue, we will update as soon as possible.
Posted May 10, 2019 - 21:19 EDT
This incident affected: vPPO.