File Download Issue
Incident Report for vCreative
Resolved
This incident has been resolved.
Posted Jul 16, 2021 - 08:38 EDT
Identified
Currently, you are unable to download, view, or listen to a file attached to a spot We are urgently working to resolve this issue.
Posted Jul 16, 2021 - 08:27 EDT
This incident affected: vPPO.